Sep 22nd, 2024 Release Deployment - EU DC
Scheduled for Sep 22, 17:00 - 20:00 IDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 19, 2024 - 11:17 IDT
Scheduled
We will be undergoing a scheduled deployment of our September 22nd release. The expected deployment duration is 3 hours on EU DC, and no downtime or disruptions are expected to occur.
Posted Sep 18, 2024 - 17:23 IDT
This scheduled maintenance affects: EU (PlainID Platform).